Dismiss Notice
It can take 24-48 hours for the hosting/Teamspeak applications to be reviewed. Opening a thread before 48 hours, asking about the application timeline will result in your account and application being deleted permanently.

Before signing up for an account, please see our Forbidden Countries List (https://www.instafree.com/forbidden_countries.php). If you are on that list, please do not attempt to sign up, as you will not be given a hosting account. Using a proxy to circumvent that list is a violation of our TOS and will result in immediate deletion of your account.

Still an issue, non https version of site still keep logging out

Discussion in 'Suggestions' started by Jase Wolf, Aug 5, 2018.

  1. Jase Wolf

    Jase Wolf Premium Hosting Client VPS Client

    Messages:
    971
    Likes Received:
    878
    Location:
    UK
    @Bryan Can you tweak the dns to stop putting www infront when you don't put http/https infront. As it's constantly wanting you to sign in on every visit coming here with www infront.
     
  2. Bryan

    Bryan Administrator

    Messages:
    6,611
    Likes Received:
    1,346
    Hi,

    It doesn't do that for me at all, in Firefox or Chrome. What browser are you using?

    Anyone else having this issue? As far as I know, it is not being forced anywhere by DNS or .htaccess.
     
  3. Konstantin

    Konstantin Premium Hosting Client VPS Client

    Messages:
    1,398
    Likes Received:
    788
    Not doing that for me? Hm. I can't seem to replicate it either.
     
  4. Jase Wolf

    Jase Wolf Premium Hosting Client VPS Client

    Messages:
    971
    Likes Received:
    878
    Location:
    UK
    Ok nevermind that was on me for not updating mobile chrome for ages lmao. Have play store auto updating disabled because every update gets so damn annoying on slow internet. But well I'm updated now lmao
     
    Bryan likes this.
  5. Konstantin

    Konstantin Premium Hosting Client VPS Client

    Messages:
    1,398
    Likes Received:
    788
    Glad it's fixed
     
    Jase Wolf likes this.
  6. Jase Wolf

    Jase Wolf Premium Hosting Client VPS Client

    Messages:
    971
    Likes Received:
    878
    Location:
    UK
    Suggestion for self:

    Keep the browser updated LOL.
     
  7. Fedora

    Fedora Premium Hosting Client VPS Client

    Messages:
    2,068
    Likes Received:
    2,135
    The wolf is out-today... :eek:

    [​IMG]
     
    Jase Wolf likes this.
  8. Jase Wolf

    Jase Wolf Premium Hosting Client VPS Client

    Messages:
    971
    Likes Received:
    878
    Location:
    UK
    Ok right mobile chrome on Android is fully updated and is still doing it with the forum, the non https is still constantly logging out afer a while. Whilst the https version works exactly as should keeping me logged in. Firstly I start having that issue on Chrome on Linux... now Chrome on Android. What next. Would go to https but it's annoying keep typing it lmao.
     
  9. Womack

    Womack Premium VPS Client Premium Hosting Client Hosting Client

    Messages:
    65
    Likes Received:
    77
    I'm curious... how are you not on https? If I type in instafree.com and click forum or type instafree.com/community it automatically redirects me to https.

    Maybe I'm missing the issue, that happens sometimes. Woooooosh.
     
  10. Jase Wolf

    Jase Wolf Premium Hosting Client VPS Client

    Messages:
    971
    Likes Received:
    878
    Location:
    UK
    Yea the homepage directs to the https version but typing the address itself without https keeps putting www infront and not https so it's not https version which is what constantly keep logging out lmao.
     
  11. Womack

    Womack Premium VPS Client Premium Hosting Client Hosting Client

    Messages:
    65
    Likes Received:
    77
    Oh for me typing in instafree.com/community redirects to the https version. That's odd.

    Scratch that, it might be Chromes autocomplete messing with it or because I'm already logged in. Tried Firefox and it doesn't...but it also doesn't add www. Hahaha
     
  12. Bryan

    Bryan Administrator

    Messages:
    6,611
    Likes Received:
    1,346
    Still not having that problem in any browser. No idea what might be causing it.
     
  13. Womack

    Womack Premium VPS Client Premium Hosting Client Hosting Client

    Messages:
    65
    Likes Received:
    77
    Have you tried a different internet connection? I wonder if it's related to an extension or something blocking cookies and XenForo relying on sessions that expire quickly. I don't know, I'm literally just guessing at this point :D

    Edit: To be clear, I have no idea what methods XenForo uses for authentication or sessions. Just brainstorming!
     
  14. Jase Wolf

    Jase Wolf Premium Hosting Client VPS Client

    Messages:
    971
    Likes Received:
    878
    Location:
    UK
    I've been on many different connections the past 2 weeks lol as I was away on the Isle of Man. All the different hotels I stayed at, still had the issue and now back home still have the issue lmao. Now if the non http/www would just redirect to https where cookies actually work, that'd help lmao. But I rather just keep tapping to log back in rather than keep typing https://ins before Chrome realises I want InstaFree lmao
     
  15. Bryan

    Bryan Administrator

    Messages:
    6,611
    Likes Received:
    1,346
    Here's the .htaccess file.

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    
    # php -- BEGIN cPanel-generated handler, do not edit
    # NOTE this account's php is controlled via FPM and the vhost, this is a place holder.
    # Do not edit. This next line is to support the cPanel php wrapper (php_cli).
    # AddType application/x-httpd-ea-php72 .php .phtml
    # php -- END cPanel-generated handler, do not edit

    The DNS doesn't do anything at all.
     
  16. Joe Rodriguez

    Joe Rodriguez Premium VPS Client Premium Hosting Client

    Messages:
    630
    Likes Received:
    440
    Location:
    Sebring, FL
    hmm.. I've had that problem since around December.. never really bothered to pin down why that was, since I always thought it was my "ever so restrictive" cookie policy.

    Does it with Chromium based and Mozilla browsers... not tried with Webkits, and well.. I bury IE in an air tight coffin.

    I just log in each time.. sometimes each page, sometimes even each post lol

    I'll try and pay more attention from this point on.
     
    Jase Wolf and Bryan like this.
  17. Bryan

    Bryan Administrator

    Messages:
    6,611
    Likes Received:
    1,346

    Oh man....that's awful. I would definitely love to get to the bottom of this and figure out why it's happening. I just don't see it being on the server side of things, as I can't replicate it at all, but who knows?
     
    Jase Wolf likes this.
  18. Joshua Johnson

    Joshua Johnson Premium Hosting Client

    Messages:
    16
    Likes Received:
    2
    Location:
    lake charles, la
    i have to do https to login to the forums
     
    Jase Wolf likes this.
  19. Joe Rodriguez

    Joe Rodriguez Premium VPS Client Premium Hosting Client

    Messages:
    630
    Likes Received:
    440
    Location:
    Sebring, FL
    The only thing I'm absolutely certain of.. is that it happens after I traverse a link... either a Topic or Thread title link or even a page in long threads... and it's not 100% of the time either, which made it seem like I've timed-out something.. why I figured it was a cookie variable.. but I'll get my shovel
     
    Jase Wolf and Bryan like this.
  20. Joe Rodriguez

    Joe Rodriguez Premium VPS Client Premium Hosting Client

    Messages:
    630
    Likes Received:
    440
    Location:
    Sebring, FL
    hmm.. 'Session_ID' got changed right around the time @Jase Wolf liked my posts... so...
    idk if it got reset via the notification system or maybe after I clicked the links from the notifications prompting me to log in to this page again in order to post.

    Before (logged in):
    [​IMG]

    After (logged out after clicking through):
    [​IMG]

    Posting ( had to log in again ):
    [​IMG]
     

Share This Page